SmarterMail 13.x Help

Browser Requirements

Desktop

SmarterMail is fully supported by the desktop browsers below.

  • Google Chrome 10 and higher
  • FireFox 3.6 and higher
  • Safari 3 and higher
  • Opera 10 and higher
  • Internet Explorer 8* and higher

Mobile

With regards to mobile browsers, the SmarterMail webmail interface works well on most major browsers available for tablets and other larger-format mobile devices (e.g., tablets and "phablets" that use mobile browsers) as long as they support CSS, JavaScript and other modern scripting platforms. Smartphone users should use the mobile interface SmarterMail provides as it is better suited for smaller screens and resolutions. For information on the SmarterMail mobile interface for smartphones, see the mobile support outlined on the jQuery mobile framework website.

* While SmarterMail will work with IE 8, it is strongly recommended that anyone using IE 8 upgrade to at least IE 9 to ensure all SmarterMail functionality works and that the interface performs as expected. IE 8 is now a legacy product and Microsoft is no longer supporting it.