SmarterStats 11.x Help

Browser Requirements

SmarterStats is fully supported by the browsers listed below:

  • Google Chrome 10 and higher
  • Firefox 3.6 and higher
  • Safari 3 and higher
  • Opera 10 and higher
  • Internet Explorer 9 and higher