SmarterTrack 12.x Help

Browser Requirements

SmarterTrack is fully supported by the browsers below:

  • Google Chrome 10 and higher
  • FireFox 3.6 and higher
  • Safari 3 and higher
  • Opera 10 and higher
  • Internet Explorer 9 and higher


With regards to mobile browsers, the SmarterTrack interface works well on most major browsers available for tablets and other larger-format mobile devices (e.g., Mobile Safari, Dolphin). For information on the SmarterTrack mobile interface for smartphones, see the mobile support outlined on the jQuery mobile framework website.