SmarterMail Help

Browser Requirements

Desktop

SmarterMail is fully supported by any modern and updated desktop browser. Minimum versions supported:

  • Google Chrome
  • FireFox
  • Microsoft Edge
  • Safari
  • Opera

Note: Any browser you use with SmarterMail should also support WebRTC to ensure video conferencing works for you and any participants. In addition, using any versions of the above browsers that are over a year old may lead to poor performance of the webmail interface.

Team Workspaces

Just as with SmarterMail in general, Team Workspaces was built to accommodate any modern, up-to-date browser. The reason for this is due to the requirements for audio, video and screen sharing available with Team Workspaces and the WebRTC protocols used on the back end. WebRTC makes real-time communciation possible within applications and is used by virtually all of the most popular web-based conferencing solutions on the market. As such, any recent browser will support Team Workspaces, and in many cases at least one or two previous versions of browsers are supported as well. That said, there are some limitations:

  • Chrome and Firefox on iOS do not support WebRTC at this time. (Safari does.)
  • WebRTC support was introducted in Safari 11. Previous versions are not supported.
  • Legacy versions of Microsoft Edge may support WebRTC. However, the newer Chromium-based Edge browser definitely supports WebRTC so an upgrade to this version is strongly recommended for the best experience.

Mobile

In addition to working with most mobile email clients, not to mention third-party calendar and/or contact apps, SmarterMail offers the same robust webmail experience on mobile as it does on the desktop. As long as the mobile browser you use supports CSS, JavaScript and other modern scripting platforms, accessing the SmarterMail webmail interface is not a problem.